summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/commonmark/commonmark-0.9.1.ebuild')
-rw-r--r--dev-python/commonmark/commonmark-0.9.1.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/commonmark/commonmark-0.9.1.ebuild b/dev-python/commonmark/commonmark-0.9.1.ebuild
deleted file mode 100644
index 7d1d0b9ea32a..000000000000
--- a/dev-python/commonmark/commonmark-0.9.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Python parser for the CommonMark Markdown spec"
-HOMEPAGE="https://github.com/readthedocs/commonmark.py"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- test? (
- >=dev-python/hypothesis-3.7.1[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests setup.py
-
-src_test() {
- local -x PYTHONIOENCODING='utf8'
- distutils-r1_src_test
-}
-
-src_prepare() {
- default
- # Fix file collision with app-text/cmark, see bug #627034
- sed -i -e "s:'cmark\( = commonmark.cmark\:main'\):'cmark.py\1:" \
- setup.py || die
-}
-
-pkg_postinst() {
- ewarn "/usr/bin/cmark has been renamed to /usr/bin/cmark.py due file"
- ewarn "collision with app-text/cmark (see bug #627034)"
-}