summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/coverage')
-rw-r--r--dev-python/coverage/Manifest2
-rw-r--r--dev-python/coverage/coverage-6.0.2.ebuild54
-rw-r--r--dev-python/coverage/coverage-6.1.1.ebuild54
3 files changed, 0 insertions, 110 deletions
diff --git a/dev-python/coverage/Manifest b/dev-python/coverage/Manifest
index c2b7e6492080..9214bd7ed5b3 100644
--- a/dev-python/coverage/Manifest
+++ b/dev-python/coverage/Manifest
@@ -1,4 +1,2 @@
-DIST coverage-6.0.2.tar.gz 722511 BLAKE2B 43a860610921fd0df106cbe26ba094e5a11bf1137a795a15bc22d82d0f813e8dc67bfe660757d325f15f719429b480ca625ebe66569489ed8c4c477bac23c393 SHA512 a43a312d4668846b6f72eebac1a289d0a603303cd32624c3308cce8934f693c7d3786b36da5cea3ff1cce60f93110a2ded168304e1ca9a79053f0886b7f1bf17
-DIST coverage-6.1.1.tar.gz 715305 BLAKE2B fbd7c8e7e1737bc8be8acf0f10c66fa333a027520b5f54869080ea9e31951230442d0d7f5a5ec11201b7ca3ba65ee92c906a373c18123920abe0d3dee5a8e040 SHA512 c029ab4e0d16e4b0a395e63e96d7a8f24bdb3a46a97fbc223d59dafaa52b8522e924a13d88777f862d69e1f30d015b00e0740530e719b6a94065d285cd3dd03a
DIST coverage-6.1.2.tar.gz 677391 BLAKE2B eb9b129282446ed536765fcbd8b31f863be315c8eb27087473608b1412014e5807a26b8bcbdeea98f7a89481198bb7475dc775e68fee53ca297d16332edb7ea8 SHA512 41b5bc881eba97308ff702024dd1873fe527c941fe1b45c36a6210819e0b6b9e6dcdf0ad31659e88ea25a3ebd84e90858694f54d2d7585c61b319edb9afbf07e
DIST coverage-6.2.tar.gz 678664 BLAKE2B 98fe2e5d85db042d95a791838b121a4aeb0edc09f15e5454943d6d1ca3cafdbf0127e8683ddcb5c1f6372b18205bf92e24a803533f19d1bdd5e0477b669cf99f SHA512 e8ef5f2483b2e6d12f0f9801d63a0cd0b81395ea0c88b3cdaf6f6758e1fc1b381f803b0f58345c94007de175d0c2a24559dec93f51db8786f801a2a2d48d6b8f
diff --git a/dev-python/coverage/coverage-6.0.2.ebuild b/dev-python/coverage/coverage-6.0.2.ebuild
deleted file mode 100644
index 4f8cb45da0dd..000000000000
--- a/dev-python/coverage/coverage-6.0.2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-PYTHON_REQ_USE="threads(+),sqlite(+)"
-inherit distutils-r1
-
-DESCRIPTION="Code coverage measurement for Python"
-HOMEPAGE="https://coverage.readthedocs.io/en/latest/ https://pypi.org/project/coverage/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-#IUSE="test"
-# The tests are impossible to appease. Please run them externally
-# via tox. Or fix the ebuild if you have hours of time to spend
-# on something utterly useless.
-RESTRICT="test"
-
-#BDEPEND="
-# test? (
-# dev-python/PyContracts[${PYTHON_USEDEP}]
-# dev-python/flaky[${PYTHON_USEDEP}]
-# dev-python/hypothesis[${PYTHON_USEDEP}]
-# dev-python/mock[${PYTHON_USEDEP}]
-# dev-python/pytest[${PYTHON_USEDEP}]
-# >=dev-python/unittest-mixins-1.4[${PYTHON_USEDEP}]
-# )
-#"
-
-src_prepare() {
- # avoid the dep on xdist, run tests verbosely
- sed -i -e '/^addopts/s:-n3:-v:' setup.cfg || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- distutils_install_for_testing
-
- "${EPYTHON}" igor.py zip_mods || die
- "${EPYTHON}" igor.py test_with_tracer py || die
-
- # No C extensions under pypy
- if [[ ${EPYTHON} != pypy* ]]; then
- cp -l -- "${TEST_DIR}"/lib/*/coverage/*.so coverage/ || die
- "${EPYTHON}" igor.py test_with_tracer c || die
- fi
-
- # clean up leftover "egg1" directory
- rm -rf build/lib/egg1 || die
-}
diff --git a/dev-python/coverage/coverage-6.1.1.ebuild b/dev-python/coverage/coverage-6.1.1.ebuild
deleted file mode 100644
index 4581809c8ea8..000000000000
--- a/dev-python/coverage/coverage-6.1.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-PYTHON_REQ_USE="threads(+),sqlite(+)"
-inherit distutils-r1
-
-DESCRIPTION="Code coverage measurement for Python"
-HOMEPAGE="https://coverage.readthedocs.io/en/latest/ https://pypi.org/project/coverage/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
-#IUSE="test"
-# The tests are impossible to appease. Please run them externally
-# via tox. Or fix the ebuild if you have hours of time to spend
-# on something utterly useless.
-RESTRICT="test"
-
-#BDEPEND="
-# test? (
-# dev-python/PyContracts[${PYTHON_USEDEP}]
-# dev-python/flaky[${PYTHON_USEDEP}]
-# dev-python/hypothesis[${PYTHON_USEDEP}]
-# dev-python/mock[${PYTHON_USEDEP}]
-# dev-python/pytest[${PYTHON_USEDEP}]
-# >=dev-python/unittest-mixins-1.4[${PYTHON_USEDEP}]
-# )
-#"
-
-src_prepare() {
- # avoid the dep on xdist, run tests verbosely
- sed -i -e '/^addopts/s:-n3:-v:' setup.cfg || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- distutils_install_for_testing
-
- "${EPYTHON}" igor.py zip_mods || die
- "${EPYTHON}" igor.py test_with_tracer py || die
-
- # No C extensions under pypy
- if [[ ${EPYTHON} != pypy* ]]; then
- cp -l -- "${TEST_DIR}"/lib/*/coverage/*.so coverage/ || die
- "${EPYTHON}" igor.py test_with_tracer c || die
- fi
-
- # clean up leftover "egg1" directory
- rm -rf build/lib/egg1 || die
-}