summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dill/dill-0.3.5.1.ebuild')
-rw-r--r--dev-python/dill/dill-0.3.5.1.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/dill/dill-0.3.5.1.ebuild b/dev-python/dill/dill-0.3.5.1.ebuild
deleted file mode 100644
index 434de8bec1ad..000000000000
--- a/dev-python/dill/dill-0.3.5.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Serialize all of Python (almost)"
-HOMEPAGE="
- https://github.com/uqfoundation/dill/
- https://pypi.org/project/dill/
-"
-SRC_URI="
- https://github.com/uqfoundation/dill/archive/${P}.tar.gz
- -> ${P}.gh.tar.gz
-"
-S=${WORKDIR}/${PN}-${P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-
-python_test() {
- local fail= t
- for t in tests/test_*.py; do
- ebegin "\t${t}"
- "${EPYTHON}" "${t}"
- eend ${?} || fail=1
- done
-
- [[ ${fail} ]] && die "Tests fail with ${EPYTHON}"
-}