summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-crispy-forms')
-rw-r--r--dev-python/django-crispy-forms/Manifest1
-rw-r--r--dev-python/django-crispy-forms/django-crispy-forms-1.4.0.ebuild31
-rw-r--r--dev-python/django-crispy-forms/metadata.xml13
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/django-crispy-forms/Manifest b/dev-python/django-crispy-forms/Manifest
new file mode 100644
index 000000000000..55e86a9b03be
--- /dev/null
+++ b/dev-python/django-crispy-forms/Manifest
@@ -0,0 +1 @@
+DIST django-crispy-forms-1.4.0.tar.gz 47444 SHA256 d0c9531ebdff8dc255f625e677ec2fab326522e3f4cd8f7a3e891d773d281510 SHA512 e06ec72a2fc44aa0f57fd507230289f78caebdb02d4af9adafd4b09a29b1df1be5301f3883c8b9007ecd0722683395451bbc382060eca5a459ddf6ef9edc2e1b WHIRLPOOL 05813292a863c69b3b0296ea7a7912bb8ca0f673fc07eaeff5053def516dc2b836725c7559e98cd8aa7ad59d4d686b2ff04bc53b027ea53413ea2329fa04e42d
diff --git a/dev-python/django-crispy-forms/django-crispy-forms-1.4.0.ebuild b/dev-python/django-crispy-forms/django-crispy-forms-1.4.0.ebuild
new file mode 100644
index 000000000000..658947e05ac6
--- /dev/null
+++ b/dev-python/django-crispy-forms/django-crispy-forms-1.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Best way to have Django DRY forms"
+HOMEPAGE="https://pypi.python.org/pypi/django-crispy-forms/ http://github.com/maraujop/django-crispy-forms https://django-crispy-forms.readthedocs.org/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# Missing DjangoTestSuiteRunner in django
+RESTRICT=test
+
+python_test() {
+ cd crispy_forms/tests || die
+ ${PYTHON} runtests.py || die
+}
diff --git a/dev-python/django-crispy-forms/metadata.xml b/dev-python/django-crispy-forms/metadata.xml
new file mode 100644
index 000000000000..3ba51420a771
--- /dev/null
+++ b/dev-python/django-crispy-forms/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">django-crispy-forms</remote-id>
+ <remote-id type="github">maraujop/django-crispy-forms</remote-id>
+ </upstream>
+</pkgmetadata>