summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dnspython/dnspython-1.15.0-r1.ebuild')
-rw-r--r--dev-python/dnspython/dnspython-1.15.0-r1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/dnspython/dnspython-1.15.0-r1.ebuild b/dev-python/dnspython/dnspython-1.15.0-r1.ebuild
deleted file mode 100644
index 9a67bca626a3..000000000000
--- a/dev-python/dnspython/dnspython-1.15.0-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="DNS toolkit for Python"
-HOMEPAGE="http://www.dnspython.org/ https://pypi.org/project/dnspython/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
- !dev-python/dnspython:py2
- !dev-python/dnspython:py3"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- app-arch/unzip"
-
-# For testsuite
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_test() {
- cd tests || die
- "${PYTHON}" utest.py || die "tests failed under ${EPYTHON}"
- einfo "Testsuite passed under ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}