summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/doublex-expects/doublex-expects-0.7.1.ebuild')
-rw-r--r--dev-python/doublex-expects/doublex-expects-0.7.1.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/doublex-expects/doublex-expects-0.7.1.ebuild b/dev-python/doublex-expects/doublex-expects-0.7.1.ebuild
deleted file mode 100644
index a657ee57441b..000000000000
--- a/dev-python/doublex-expects/doublex-expects-0.7.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit distutils-r1
-
-MY_PV=${PV/_/}
-
-DESCRIPTION="Expects matchers for Doublex test doubles assertions"
-HOMEPAGE="https://github.com/jaimegildesagredo/doublex-expects"
-SRC_URI="https://github.com/jaimegildesagredo/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/doublex[${PYTHON_USEDEP}]
- >=dev-python/expects-0.8.0_rc1[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-python/mamba[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- mamba || die "Tests failed under ${EPYTHON}"
-}