summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/elasticsearch-curator')
-rw-r--r--dev-python/elasticsearch-curator/Manifest6
-rw-r--r--dev-python/elasticsearch-curator/elasticsearch-curator-2.1.2.ebuild79
-rw-r--r--dev-python/elasticsearch-curator/elasticsearch-curator-3.0.0.ebuild94
-rw-r--r--dev-python/elasticsearch-curator/elasticsearch-curator-3.2.3.ebuild99
-rw-r--r--dev-python/elasticsearch-curator/metadata.xml16
5 files changed, 294 insertions, 0 deletions
diff --git a/dev-python/elasticsearch-curator/Manifest b/dev-python/elasticsearch-curator/Manifest
new file mode 100644
index 000000000000..70b47b7d97b1
--- /dev/null
+++ b/dev-python/elasticsearch-curator/Manifest
@@ -0,0 +1,6 @@
+DIST elasticsearch-1.4.2.tar.gz 27734207 SHA256 31dd6c049745f7dac201f94852b778b0841d6869d358fd80d4c897d0bf73b53c SHA512 b82e644b0b81489ce0d4fc72ca0efa3545c55c4d947faec2537035d440be83bac0f794f1a2863d87649e36f87d250c1f4e46ae57053b50948f47f9ff2a3bf6b6 WHIRLPOOL ac40778a999bc92230547b1405f259b7d348983767a87c71e18ed9ef45367ebf0b5b0517ef57bd423fa47ce4387e982aa7ee4a4ec9b2be75a4771e8d737f0cc5
+DIST elasticsearch-1.4.4.tar.gz 27900004 SHA256 a3158d474e68520664debaea304be22327fc7ee1f410e0bfd940747b413e8586 SHA512 afc24c5d778d346e24c656e040fb7d0036e16ae42b35ca4f97b2e4d31dc815467ae5462f922ea5222307acf0fa0579f6cd38c603bc996c1f4ba723aa6a2b01ed WHIRLPOOL 37a1a057539ae29525a78fa51f3d19f403e389129e54054edfa1bbd08d12bdbb88acb4e879b6795aa63d583fd70eedefcae5b13b6bf1a7c8314e3aafa49e2b33
+DIST elasticsearch-1.7.0.tar.gz 28501532 SHA256 6fabed2db09e1b88587df15269df328ecef33e155b3c675a2a6d2299bda09c95 SHA512 090186218d7bfcef2f1cf497b08edeae71f2bdae1ddbe97a04e3e288c9a41bdf069ee7ef51202596b17ac9a33840edc4d655a08313ecb732a1f37029b60740d4 WHIRLPOOL 0dfd8f5095dfbbbcda788da0661fc5ec9af7d2fa174dbb365ad021ff7e48d42035f63a45ba6cb9fc20fc8e86500fc81cfcb2f0c46f99015b6f84a2c2be762bd4
+DIST elasticsearch-curator-2.1.2.tar.gz 35706 SHA256 93185f57e4fcd84970b78936271c3ddcba69c54d9a799acafe7d16483134cce0 SHA512 4bc4f74ab7d710173f173d47ad5e8c8918267bbc888a2b1b301e799747f73375b159671940cf7d3cc62361adbb320bc3e772d149eb7ff227d4893788810946f1 WHIRLPOOL 156e92a0a5fa4797651d1c066b955304b082edcda815784c5ddb5a025c93f9b4f222f15e5d7ce74e4740bd1c3ab5e67fe21e651186e0062ff3f0e418b0390b09
+DIST elasticsearch-curator-3.0.0.tar.gz 55418 SHA256 72ec58f15344649dbfec54c80731e6b0b80bb3c0575061ca75580d49f9982fe0 SHA512 acf2a86af682118a0c5ece1d8b557e6b43ada667f8c172cd7d8f66280b07e5e79ec6da5a674b338348fc1e94a6d2bcffd8e1ff61f7bd9ef43cd6458eb371c50a WHIRLPOOL bab3479082209c1efea77b6385a49782617143fd28c6956c13cbc3c1d36256c3d45c316abb3b6982e5822b811ac69a18cfcaa5dc4ec4e3634b155a241d0cb0f4
+DIST elasticsearch-curator-3.2.3.tar.gz 82745 SHA256 f3e499719cd7e0d13a6e7e339c034ed91039f9295767484bd217574fd1a04a9e SHA512 55668d7c5d0cda386983f499e93bba5f2ff1520569ee6e3ac296b1dc86daf302ec6a5c5c8c0eb48e821ace2c40fa523990a06dcd1099b1359dd15ae5dbfe5ae4 WHIRLPOOL 06ac9e72a43731ba864fb883b2a89da82e0a12249ba3962f9ce9ebe2fb41dbea6bb378cf05d365e1379d3836183a0c75aae4e8c87b123a211f55cbf0258e7d53
diff --git a/dev-python/elasticsearch-curator/elasticsearch-curator-2.1.2.ebuild b/dev-python/elasticsearch-curator/elasticsearch-curator-2.1.2.ebuild
new file mode 100644
index 000000000000..81749c806cfb
--- /dev/null
+++ b/dev-python/elasticsearch-curator/elasticsearch-curator-2.1.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+MY_PN="curator"
+ES_VERSION="1.4.2"
+
+inherit distutils-r1
+
+DESCRIPTION="Tending time-series indices in Elasticsearch"
+HOMEPAGE="https://github.com/elasticsearch/curator"
+SRC_URI="https://github.com/elasticsearch/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-${ES_VERSION}.tar.gz )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/elasticsearch-py-1.0.0[${PYTHON_USEDEP}]
+ <dev-python/elasticsearch-py-2.0.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ virtual/jre:1.7
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/nosexcover[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ ES="${WORKDIR}/elasticsearch-${ES_VERSION}"
+ ES_PORT="25123"
+ ES_LOG="${ES}/logs/elasticsearch.log"
+ PID="${ES}/elasticsearch.pid"
+
+ # run Elasticsearch instance on custom port
+ sed -i "s/#http.port: 9200/http.port: ${ES_PORT}/g" ${ES}/config/elasticsearch.yml
+ ${ES}/bin/elasticsearch -d -p ${PID}
+
+ for i in `seq 10`; do
+ grep -q "started" ${ES_LOG} 2> /dev/null
+ if [ $? -eq 0 ]; then
+ einfo "Elasticsearch started"
+ eend 0
+ break
+ elif grep -q 'BindException\[Address already in use\]' "${ES_LOG}" 2>/dev/null; then
+ eend 1
+ eerror "Elasticsearch already running"
+ die "Cannot start Elasticsearch for tests"
+ else
+ einfo "Waiting for Elasticsearch"
+ eend 1
+ sleep 2
+ continue
+ fi
+ done
+
+ export TEST_ES_SERVER="localhost:${ES_PORT}"
+ esetup.py test || die "Tests failed on ${EPYTHON}"
+
+ pkill -F ${PID}
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/elasticsearch-curator/elasticsearch-curator-3.0.0.ebuild b/dev-python/elasticsearch-curator/elasticsearch-curator-3.0.0.ebuild
new file mode 100644
index 000000000000..8fcfbd883479
--- /dev/null
+++ b/dev-python/elasticsearch-curator/elasticsearch-curator-3.0.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+MY_PN="curator"
+ES_VERSION="1.4.4"
+
+inherit distutils-r1
+
+DESCRIPTION="Tending time-series indices in Elasticsearch"
+HOMEPAGE="https://github.com/elasticsearch/curator"
+SRC_URI="https://github.com/elasticsearch/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-${ES_VERSION}.tar.gz )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/elasticsearch-py-1.0.0[${PYTHON_USEDEP}]
+ <dev-python/elasticsearch-py-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/click-3.3[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ virtual/jre:1.7
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/nosexcover[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ ES="${WORKDIR}/elasticsearch-${ES_VERSION}"
+ ES_PORT="25123"
+ ES_LOG="${ES}/logs/elasticsearch.log"
+ PID="${ES}/elasticsearch.pid"
+
+ # run Elasticsearch instance on custom port
+ sed -i "s/#http.port: 9200/http.port: ${ES_PORT}/g; \
+ s/#cluster.name: elasticsearch/cluster.name: gentoo-es-curator-test/g" \
+ ${ES}/config/elasticsearch.yml
+
+ # start local instance of elasticsearch
+ ${ES}/bin/elasticsearch -d -p ${PID}
+
+ for i in `seq 10`; do
+ grep -q "started" ${ES_LOG} 2> /dev/null
+ if [ $? -eq 0 ]; then
+ einfo "Elasticsearch started"
+ eend 0
+ break
+ elif grep -q 'BindException\[Address already in use\]' "${ES_LOG}" 2>/dev/null; then
+ eend 1
+ eerror "Elasticsearch already running"
+ die "Cannot start Elasticsearch for tests"
+ else
+ einfo "Waiting for Elasticsearch"
+ eend 1
+ sleep 2
+ continue
+ fi
+ done
+
+ export TEST_ES_SERVER="localhost:${ES_PORT}"
+ esetup.py test || die "Tests failed on ${EPYTHON}"
+
+ pkill -F ${PID}
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ ewarn ""
+ ewarn "For Python 3 support information please read: http://click.pocoo.org/3/python3/"
+ ewarn ""
+ ewarn "Example usage on Python 3:"
+ ewarn "export LC_ALL=en_US.UTF-8"
+ ewarn "export LANG=en_US.UTF-8"
+ ewarn "curator ..."
+}
diff --git a/dev-python/elasticsearch-curator/elasticsearch-curator-3.2.3.ebuild b/dev-python/elasticsearch-curator/elasticsearch-curator-3.2.3.ebuild
new file mode 100644
index 000000000000..0300333aeb21
--- /dev/null
+++ b/dev-python/elasticsearch-curator/elasticsearch-curator-3.2.3.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+MY_PN="curator"
+ES_VERSION="1.7.0"
+
+inherit distutils-r1
+
+DESCRIPTION="Tending time-series indices in Elasticsearch"
+HOMEPAGE="https://github.com/elasticsearch/curator"
+SRC_URI="https://github.com/elasticsearch/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-${ES_VERSION}.tar.gz )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/elasticsearch-py-1.0.0[${PYTHON_USEDEP}]
+ <dev-python/elasticsearch-py-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/click-3.3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ || ( virtual/jre:1.8 virtual/jre:1.7 )
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/nosexcover[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ ES="${WORKDIR}/elasticsearch-${ES_VERSION}"
+ ES_PORT="25123"
+ ES_LOG="${ES}/logs/elasticsearch.log"
+ PID="${ES}/elasticsearch.pid"
+
+ # run Elasticsearch instance on custom port
+ sed -i "s/#http.port: 9200/http.port: ${ES_PORT}/g; \
+ s/#cluster.name: elasticsearch/cluster.name: gentoo-es-curator-test/g" \
+ ${ES}/config/elasticsearch.yml
+
+ # Elasticsearch 1.6+ needs to set path.repo
+ echo "path.repo: /" >> ${ES}/config/elasticsearch.yml
+
+ # start local instance of elasticsearch
+ ${ES}/bin/elasticsearch -d -p ${PID}
+
+ for i in `seq 10`; do
+ grep -q "started" ${ES_LOG} 2> /dev/null
+ if [ $? -eq 0 ]; then
+ einfo "Elasticsearch started"
+ eend 0
+ break
+ elif grep -q 'BindException\[Address already in use\]' "${ES_LOG}" 2>/dev/null; then
+ eend 1
+ eerror "Elasticsearch already running"
+ die "Cannot start Elasticsearch for tests"
+ else
+ einfo "Waiting for Elasticsearch"
+ eend 1
+ sleep 2
+ continue
+ fi
+ done
+
+ export TEST_ES_SERVER="localhost:${ES_PORT}"
+ esetup.py test || die "Tests failed on ${EPYTHON}"
+
+ pkill -F ${PID}
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ ewarn ""
+ ewarn "For Python 3 support information please read: http://click.pocoo.org/3/python3/"
+ ewarn ""
+ ewarn "Example usage on Python 3:"
+ ewarn "export LC_ALL=en_US.UTF-8"
+ ewarn "export LANG=en_US.UTF-8"
+ ewarn "curator ..."
+}
diff --git a/dev-python/elasticsearch-curator/metadata.xml b/dev-python/elasticsearch-curator/metadata.xml
new file mode 100644
index 000000000000..ffe20745f0fd
--- /dev/null
+++ b/dev-python/elasticsearch-curator/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>idella4@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>hydrapolic@gmail.com</email>
+ <name>Tomas Mozes</name>
+ <description>Proxy maintainer</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">elasticsearch/curator</remote-id>
+ </upstream>
+</pkgmetadata>