summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/elementpath/elementpath-3.0.1.ebuild')
-rw-r--r--dev-python/elementpath/elementpath-3.0.1.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/elementpath/elementpath-3.0.1.ebuild b/dev-python/elementpath/elementpath-3.0.1.ebuild
deleted file mode 100644
index 44481bdc806a..000000000000
--- a/dev-python/elementpath/elementpath-3.0.1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 2019-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
-HOMEPAGE="
- https://github.com/sissaschool/elementpath/
- https://pypi.org/project/elementpath/
-"
-SRC_URI="
- https://github.com/sissaschool/elementpath/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
-
-BDEPEND="
- test? (
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/xmlschema[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # fails for some reason, more fit for upstream testing anyway
- rm tests/test_typing.py || die
- distutils-r1_src_prepare
-}