summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/emcee/emcee-3.1.0.ebuild')
-rw-r--r--dev-python/emcee/emcee-3.1.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/emcee/emcee-3.1.0.ebuild b/dev-python/emcee/emcee-3.1.0.ebuild
new file mode 100644
index 000000000000..4939478f08ba
--- /dev/null
+++ b/dev-python/emcee/emcee-3.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python ensemble sampling toolkit for affine-invariant MCMC"
+HOMEPAGE="https://emcee.readthedocs.io/en/stable/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+DOCS=( AUTHORS.rst README.rst )
+
+src_prepare() {
+ # unnecessary dep
+ sed -i -e '/wheel/d' setup.py || die
+ distutils-r1_src_prepare
+}