summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/empy/empy-3.3.4.ebuild')
-rw-r--r--dev-python/empy/empy-3.3.4.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/empy/empy-3.3.4.ebuild b/dev-python/empy/empy-3.3.4.ebuild
deleted file mode 100644
index af1f703d494c..000000000000
--- a/dev-python/empy/empy-3.3.4.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A powerful and robust templating system for Python"
-HOMEPAGE="http://www.alcyone.com/software/empy/"
-SRC_URI="http://www.alcyone.com/software/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ia64 ppc x86"
-IUSE="doc"
-
-python_test() {
- "${PYTHON}" em.py sample.em | diff sample.bench -
- if [[ ${PIPESTATUS[0]} -ne 0 || ${PIPESTATUS[1]} -ne 0 ]]; then
- die "Testing failed with ${EPYTHON}"
- fi
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use doc; then
- docinto examples
- dodoc sample.em sample.bench
- # 3.3 has the html in this funny place. Fix in later version:
- docinto html
- dodoc doc/home/max/projects/empy/doc/em/*
- dodoc doc/home/max/projects/empy/doc/em.html
- dodoc doc/index.html
- fi
-}