summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ensurepip-pip/ensurepip-pip-23.1.2.ebuild')
-rw-r--r--dev-python/ensurepip-pip/ensurepip-pip-23.1.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/ensurepip-pip/ensurepip-pip-23.1.2.ebuild b/dev-python/ensurepip-pip/ensurepip-pip-23.1.2.ebuild
new file mode 100644
index 000000000000..8a4b916f03bd
--- /dev/null
+++ b/dev-python/ensurepip-pip/ensurepip-pip-23.1.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit pypi
+
+DESCRIPTION="Shared pip wheel for ensurepip Python module"
+HOMEPAGE="https://pypi.org/project/pip/"
+SRC_URI="$(pypi_wheel_url "${PN#ensurepip-}")"
+S=${DISTDIR}
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC LGPL-2.1+ MIT MPL-2.0 PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ !<dev-python/ensurepip-wheels-100
+"
+
+src_install() {
+ insinto /usr/lib/python/ensurepip
+ doins "${A}"
+}