summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/enzyme/enzyme-9999.ebuild')
-rw-r--r--dev-python/enzyme/enzyme-9999.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/enzyme/enzyme-9999.ebuild b/dev-python/enzyme/enzyme-9999.ebuild
deleted file mode 100644
index 40184beaebb1..000000000000
--- a/dev-python/enzyme/enzyme-9999.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8,9} )
-PYTHON_REQ_USE='xml(+)'
-
-inherit distutils-r1 git-r3
-
-DESCRIPTION="Python video metadata parser"
-HOMEPAGE="https://github.com/Diaoul/enzyme https://pypi.org/project/enzyme/"
-EGIT_REPO_URI="https://github.com/Diaoul/${PN}.git"
-SRC_URI="test? ( mirror://sourceforge/matroska/test_files/matroska_test_w1_1.zip )"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- test? (
- app-arch/unzip
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests setup.py
-
-src_unpack() {
- default_src_unpack
- git-r3_src_unpack
-}
-
-python_prepare_all() {
- if use test; then
- mkdir enzyme/tests/test_{mkv,parsers} || die
- ln -s "${WORKDIR}"/test*.mkv enzyme/tests/test_mkv/ || die
- ln -s "${WORKDIR}"/test*.mkv enzyme/tests/test_parsers/ || die
- fi
-
- distutils-r1_python_prepare_all
-}