summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/extras/extras-1.0.0-r2.ebuild')
-rw-r--r--dev-python/extras/extras-1.0.0-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/extras/extras-1.0.0-r2.ebuild b/dev-python/extras/extras-1.0.0-r2.ebuild
new file mode 100644
index 000000000000..4e4df97d4a9b
--- /dev/null
+++ b/dev-python/extras/extras-1.0.0-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Useful extra bits for Python that should be in the standard library"
+HOMEPAGE="
+ https://github.com/testing-cabal/extras/
+ https://pypi.org/project/extras/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest