summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/eyeD3/eyeD3-0.7.5.ebuild')
-rw-r--r--dev-python/eyeD3/eyeD3-0.7.5.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/eyeD3/eyeD3-0.7.5.ebuild b/dev-python/eyeD3/eyeD3-0.7.5.ebuild
deleted file mode 100644
index cf82f7e516dd..000000000000
--- a/dev-python/eyeD3/eyeD3-0.7.5.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# still appears ill prepared for python3; see bugs 501338, 501340
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Module for manipulating ID3 (v1 + v2) tags in Python"
-HOMEPAGE="http://eyed3.nicfit.net/"
-SRC_URI="http://eyed3.nicfit.net/releases/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0.7"
-KEYWORDS="~alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x86-solaris"
-IUSE=""
-
-DEPEND="dev-python/paver[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- # prevent the build system from installing unwrapped bash script
- # and prevent it from pulling optional python-magic
- sed -i -e '/scripts/d' \
- -e '/install_requires/d' pavement.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_install() {
- distutils-r1_python_install
-
- sed -e "s:python:${EPYTHON}:" bin/eyeD3 > "${TMPDIR}"/eyeD3 || die
- python_doexe "${TMPDIR}"/eyeD3
-}