summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fasteners/fasteners-0.16.3.ebuild')
-rw-r--r--dev-python/fasteners/fasteners-0.16.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/fasteners/fasteners-0.16.3.ebuild b/dev-python/fasteners/fasteners-0.16.3.ebuild
new file mode 100644
index 000000000000..87fc43fd2b6e
--- /dev/null
+++ b/dev-python/fasteners/fasteners-0.16.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package that provides useful locks"
+HOMEPAGE="https://github.com/harlowja/fasteners/"
+SRC_URI="
+ https://github.com/harlowja/fasteners/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/diskcache[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest