summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fields/fields-5.0.0-r2.ebuild')
-rw-r--r--dev-python/fields/fields-5.0.0-r2.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/fields/fields-5.0.0-r2.ebuild b/dev-python/fields/fields-5.0.0-r2.ebuild
deleted file mode 100644
index c31892fdbb2b..000000000000
--- a/dev-python/fields/fields-5.0.0-r2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Container class boilerplate killer"
-HOMEPAGE="https://github.com/ionelmc/python-fields"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-BDEPEND="
- test? (
- dev-python/attrs[${PYTHON_USEDEP}]
- dev-python/characteristic[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed -r \
- -e "/--benchmark-disable/d" \
- -e 's|\[pytest\]|\[tool:pytest\]|' \
- -i setup.cfg || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- epytest --ignore tests/test_perf.py tests
-}