summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/filetype/filetype-1.0.8.ebuild')
-rw-r--r--dev-python/filetype/filetype-1.0.8.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/dev-python/filetype/filetype-1.0.8.ebuild b/dev-python/filetype/filetype-1.0.8.ebuild
new file mode 100644
index 000000000000..d13aeb5a02d6
--- /dev/null
+++ b/dev-python/filetype/filetype-1.0.8.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Small, dependency-free, fast Python package to infer binary file types checking"
+HOMEPAGE="https://github.com/h2non/filetype.py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+distutils_enable_tests unittest