summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fixtures')
-rw-r--r--dev-python/fixtures/Manifest4
-rw-r--r--dev-python/fixtures/fixtures-0.3.14-r2.ebuild31
-rw-r--r--dev-python/fixtures/fixtures-1.2.0.ebuild28
-rw-r--r--dev-python/fixtures/fixtures-1.3.0.ebuild29
-rw-r--r--dev-python/fixtures/fixtures-1.3.1-r1.ebuild31
-rw-r--r--dev-python/fixtures/metadata.xml20
6 files changed, 143 insertions, 0 deletions
diff --git a/dev-python/fixtures/Manifest b/dev-python/fixtures/Manifest
new file mode 100644
index 000000000000..e77ecb0acf1b
--- /dev/null
+++ b/dev-python/fixtures/Manifest
@@ -0,0 +1,4 @@
+DIST fixtures-0.3.14.tar.gz 34586 SHA256 4cc3313e52519d2671bd22aacd4b3fde9d96b31eb49db04a7cd5ccc61fec5139 SHA512 096466bfd2d2c2bb73461145e060d351fb4cba4ab52885ee7dc376ce68aced190d4f8d9969e7a94fcf90dcafd9bd6579a3ce2bcccfee33218571cb84c87ac795 WHIRLPOOL ee32650518e8a0fa86f7064d7a4952caed8a4f51a69de959014f82c58ac60765b13e02486261dca118194c683d056d5f3fb2ff0cdccd9abec7316e095862b7a5
+DIST fixtures-1.2.0.tar.gz 45318 SHA256 bb3b677a069d9fc3eb0fbc452965ac8a6c95edc778f3bd05b789ed46d1527b01 SHA512 c2730a2bb1cd5d7fbdf0499fa3cf3b62063d4632207a15e40fa0f6a4ccc0fa0afa786a115ac02cf01eaaac931ea1927bf979ffd446ec41d324862b3f69a8e9c7 WHIRLPOOL 322af23609b331023d03a27305c22e9b078f9d7f08924e217b525a5a64b6c28eec7262c9500cb3fe830095a7a693d0bdc84f952525d94bb1e7e56e627590eb8d
+DIST fixtures-1.3.0.tar.gz 48941 SHA256 81c43b99ee63b2849a7a07c2ddcf147dea0c36260cd71352b649397d427d8f30 SHA512 48bcfd125af25cb594a01b5509730acf1ab8dcc3b19d67c572bad8fb4cd837bd02caa3086bd937fcf5e0ff72cf404988333899471103f37ecff54445e928e433 WHIRLPOOL e871e2092eecadf8a1b1fcd568d3704962e5b03b8374ec3bfee74dedbc1dee5efc3d24b1054e3424ed64830e2f94b1828948810052ef3dccfe5f9051df64c920
+DIST fixtures-1.3.1.tar.gz 49741 SHA256 b63cf3bb37f83ff815456e2d0e118535ae9a4bf43e76d9a1cf3286041bf717ce SHA512 ce6ec1e1edeca34cdca86ca802cf1a468dde141f1ce2345ae9d9fd797e5ae4f9d69f9adbbbc90c6f8f070c6e75932f6d34f08a2f3d2d3109c7c7334cc4e3fe68 WHIRLPOOL 9b94c3a727ad46bee4cb99c2b907c0f38c7a2cf07846abfa90f8996849313dbf27d26742565853eaa580ddd9d42a3176ce691dd25fee5cdd8a1046866bb46695
diff --git a/dev-python/fixtures/fixtures-0.3.14-r2.ebuild b/dev-python/fixtures/fixtures-0.3.14-r2.ebuild
new file mode 100644
index 000000000000..93a2d52e772e
--- /dev/null
+++ b/dev-python/fixtures/fixtures-0.3.14-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Fixtures, reusable state for writing clean tests and more"
+HOMEPAGE="https://launchpad.net/python-fixtures https://pypi.python.org/pypi/fixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# nose not listed but provides coverage output of tests
+# run of test files by python lacks any output except on fail
+DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.22[${PYTHON_USEDEP}]
+ dev-python/extras[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/testtools-0.9.22"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ pushd "${BUILD_DIR}"/ > /dev/null
+ ln -sf ../README .
+ nosetests lib/${PN}/tests/test_*.py || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/fixtures/fixtures-1.2.0.ebuild b/dev-python/fixtures/fixtures-1.2.0.ebuild
new file mode 100644
index 000000000000..30711fa855fb
--- /dev/null
+++ b/dev-python/fixtures/fixtures-1.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fixtures, reusable state for writing clean tests and more"
+HOMEPAGE="https://launchpad.net/python-fixtures https://pypi.python.org/pypi/fixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# nose not listed but provides coverage output of tests
+# run of test files by python lacks any output except on fail
+DEPEND="test? ( >=dev-python/testtools-0.9.22[${PYTHON_USEDEP}]
+ dev-python/extras[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/testtools-0.9.22"
+#DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ emake check
+}
diff --git a/dev-python/fixtures/fixtures-1.3.0.ebuild b/dev-python/fixtures/fixtures-1.3.0.ebuild
new file mode 100644
index 000000000000..4368613f0bf6
--- /dev/null
+++ b/dev-python/fixtures/fixtures-1.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fixtures, reusable state for writing clean tests and more"
+HOMEPAGE="https://launchpad.net/python-fixtures https://pypi.python.org/pypi/fixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# nose not listed but provides coverage output of tests
+# run of test files by python lacks any output except on fail
+RDEPEND="dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.22[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+#DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ emake check
+}
diff --git a/dev-python/fixtures/fixtures-1.3.1-r1.ebuild b/dev-python/fixtures/fixtures-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..56e3e7490ed5
--- /dev/null
+++ b/dev-python/fixtures/fixtures-1.3.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Fixtures, reusable state for writing clean tests and more"
+HOMEPAGE="https://launchpad.net/python-fixtures https://pypi.python.org/pypi/fixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# nose not listed but provides coverage output of tests
+# run of test files by python lacks any output except on fail
+RDEPEND="
+ >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.22[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[$(python_gen_usedep python2_7 pypy)] )"
+#DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ emake check
+}
diff --git a/dev-python/fixtures/metadata.xml b/dev-python/fixtures/metadata.xml
new file mode 100644
index 000000000000..af43239d85e1
--- /dev/null
+++ b/dev-python/fixtures/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Fixtures defines a Python contract for reusable state / support logic,
+ primarily for unit testing. Helper and adaption logic is included to make
+ it easy to write your own fixtures using the fixtures contract. Glue code
+ is provided that makes using fixtures that meet the Fixtures contract in
+ unittest compatible test cases easy and straight forward.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">fixtures</remote-id>
+ <remote-id type="launchpad">python-fixtures</remote-id>
+ </upstream>
+</pkgmetadata>