summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flake8/flake8-3.9.2.ebuild')
-rw-r--r--dev-python/flake8/flake8-3.9.2.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/flake8/flake8-3.9.2.ebuild b/dev-python/flake8/flake8-3.9.2.ebuild
deleted file mode 100644
index 48d4b58f1fa9..000000000000
--- a/dev-python/flake8/flake8-3.9.2.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7..9} )
-inherit distutils-r1
-
-DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
-HOMEPAGE="https://gitlab.com/pycqa/flake8 https://pypi.org/project/flake8/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-# requires.txt inc. mccabe however that creates a circular dep
-RDEPEND="
- >=dev-python/pyflakes-2.3.0[${PYTHON_USEDEP}]
- <dev-python/pyflakes-2.4.0[${PYTHON_USEDEP}]
- >=dev-python/pycodestyle-2.7.0[${PYTHON_USEDEP}]
- <dev-python/pycodestyle-2.8.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' pypy3 python3_{6,7})
-"
-PDEPEND="
- >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
-"
-BDEPEND="${RDEPEND}
- test? (
- ${PDEPEND}
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs/source dev-python/sphinx-prompt dev-python/sphinx_rtd_theme
-distutils_enable_tests --install pytest