summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-paranoid/flask-paranoid-0.3.0.ebuild')
-rw-r--r--dev-python/flask-paranoid/flask-paranoid-0.3.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/flask-paranoid/flask-paranoid-0.3.0.ebuild b/dev-python/flask-paranoid/flask-paranoid-0.3.0.ebuild
new file mode 100644
index 000000000000..3cc4a2f60f52
--- /dev/null
+++ b/dev-python/flask-paranoid/flask-paranoid-0.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple user session protection extension for Flask"
+HOMEPAGE="
+ https://github.com/miguelgrinberg/flask-paranoid/
+ https://pypi.org/project/Flask-Paranoid/
+"
+SRC_URI="
+ https://github.com/miguelgrinberg/flask-paranoid/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm64 x86"
+
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest