summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-testing/flask-testing-0.4.2.ebuild')
-rw-r--r--dev-python/flask-testing/flask-testing-0.4.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/flask-testing/flask-testing-0.4.2.ebuild b/dev-python/flask-testing/flask-testing-0.4.2.ebuild
new file mode 100644
index 000000000000..c9c8d5279031
--- /dev/null
+++ b/dev-python/flask-testing/flask-testing-0.4.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_PN="Flask-Testing"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Unit testing for Flask"
+HOMEPAGE="http://pythonhosted.org/Flask-Testing/ https://pypi.python.org/pypi/Flask-Testing/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/twill[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}"/${PV}-test-fix.patch )
+
+python_test() {
+ # test phase appears to run only py2.7 but if it passes for py2.7 is passes for pypy
+ nosetests || die "Testing failed with ${EPYTHON}"
+}