summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fritzconnection/fritzconnection-1.5.0.ebuild')
-rw-r--r--dev-python/fritzconnection/fritzconnection-1.5.0.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-python/fritzconnection/fritzconnection-1.5.0.ebuild b/dev-python/fritzconnection/fritzconnection-1.5.0.ebuild
deleted file mode 100644
index 558c9ac45bc5..000000000000
--- a/dev-python/fritzconnection/fritzconnection-1.5.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Lib/tool to communicate with AVM FRITZ! devices using TR-064 protocol over UPnP"
-HOMEPAGE="https://github.com/kbr/fritzconnection"
-LICENSE="MIT"
-SLOT="0"
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/kbr/fritzconnection"
- inherit git-r3
-else
- SRC_URI="https://github.com/kbr/fritzconnection/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-CDEPEND=">=dev-python/requests-2.22[${PYTHON_USEDEP}]"
-
-BDEPEND="
- test? (
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-DEPEND="test? ( ${CDEPEND} )"
-
-RDEPEND="${CDEPEND}"
-
-distutils_enable_tests pytest