summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/globre/globre-0.1.2-r1.ebuild')
-rw-r--r--dev-python/globre/globre-0.1.2-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/globre/globre-0.1.2-r1.ebuild b/dev-python/globre/globre-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..4e7447e834cf
--- /dev/null
+++ b/dev-python/globre/globre-0.1.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A glob matching library, providing an interface similar to the 're' module"
+HOMEPAGE="https://pypi.python.org/pypi/globre http://github.com/metagriffin/globre"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ sed \
+ -e '/distribute/d' \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests --verbose || die
+}