summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/google-apitools/google-apitools-0.5.22.ebuild')
-rw-r--r--dev-python/google-apitools/google-apitools-0.5.22.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/google-apitools/google-apitools-0.5.22.ebuild b/dev-python/google-apitools/google-apitools-0.5.22.ebuild
new file mode 100644
index 000000000000..d848410aa32c
--- /dev/null
+++ b/dev-python/google-apitools/google-apitools-0.5.22.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+# Python 3 support: https://github.com/google/apitools/issues/8
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to manipulate Google APIs"
+HOMEPAGE="https://github.com/google/apitools"
+SRC_URI="https://github.com/google/apitools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.14[${PYTHON_USEDEP}]
+ >=dev-python/oauth2client-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/google-apputils-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/python-gflags-3.0.6[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-18.5[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/apitools-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.5.22-use-friendy-version-checks.patch
+)