summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/greenlet/greenlet-0.4.12.ebuild')
-rw-r--r--dev-python/greenlet/greenlet-0.4.12.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/greenlet/greenlet-0.4.12.ebuild b/dev-python/greenlet/greenlet-0.4.12.ebuild
deleted file mode 100644
index dc2af69268c3..000000000000
--- a/dev-python/greenlet/greenlet-0.4.12.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# Note: greenlet is built-in in pypy
-PYTHON_COMPAT=( python2_7 python3_6 )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Lightweight in-process concurrent programming"
-HOMEPAGE="https://pypi.org/project/greenlet/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="-alpha amd64 arm arm64 -hppa -ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile() {
- if [[ ${EPYTHON} == python2.7 ]]; then
- local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}
- append-flags -fno-strict-aliasing
- fi
-
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- "${PYTHON}" run-tests.py -n || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
- distutils-r1_python_install_all
-}