summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/greenlet')
-rw-r--r--dev-python/greenlet/Manifest1
-rw-r--r--dev-python/greenlet/greenlet-0.4.17.ebuild36
2 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/greenlet/Manifest b/dev-python/greenlet/Manifest
index 7ec4497a33b9..17c616a10d9c 100644
--- a/dev-python/greenlet/Manifest
+++ b/dev-python/greenlet/Manifest
@@ -1,2 +1 @@
-DIST greenlet-0.4.17.tar.gz 61381 BLAKE2B fd5b8ed72acd390f3d5fe3ca1d5894bc47278b1f0e04e4fe5c6015c60dfb3109e766dc6072bf85b96760f673a1af08cd546171906800a1221a216899077a908e SHA512 41afd80a6cd5e9cf9c8149016f24d0944d2651288d50094ef04bb6759202903c436af639872d7aab631ed8fe13aad7d4405beb428415b198a3ba30a96d4bd3de
DIST greenlet-1.0.0.tar.gz 84525 BLAKE2B b5b7094a3dd7b6426fb93fb147077e98e7313700be7a94c221cda3df3bb12f5322f0cea786b77b7b6500e5e97f71ba19b2c32535ccdbdf8a14c3db049cc2850a SHA512 7b615792c340e0eb8ca61bd09bde48ed15110d97254910bd8598312e15adb7267ba795e9e6b52f0998db27d8413d2e1aa9e977511c0d09cd3a5583b37475f882
diff --git a/dev-python/greenlet/greenlet-0.4.17.ebuild b/dev-python/greenlet/greenlet-0.4.17.ebuild
deleted file mode 100644
index 6a3c5bcad6dc..000000000000
--- a/dev-python/greenlet/greenlet-0.4.17.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# setuptools is used only if one of the fancy commands are used
-DISTUTILS_USE_SETUPTOOLS=no
-# Note: greenlet is built-in in pypy
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Lightweight in-process concurrent programming"
-HOMEPAGE="https://pypi.org/project/greenlet/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 -hppa -ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-distutils_enable_sphinx doc --no-autodoc
-
-python_compile() {
- if ! python_is_python3; then
- local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}
- append-flags -fno-strict-aliasing
- fi
-
- distutils-r1_python_compile
-}
-
-python_test() {
- "${PYTHON}" run-tests.py -n || die "Tests fail with ${EPYTHON}"
-}