summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gsd/gsd-2.6.0.ebuild')
-rw-r--r--dev-python/gsd/gsd-2.6.0.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/gsd/gsd-2.6.0.ebuild b/dev-python/gsd/gsd-2.6.0.ebuild
deleted file mode 100644
index f0c47aecddbe..000000000000
--- a/dev-python/gsd/gsd-2.6.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-MY_P=${P/-/-v}
-DESCRIPTION="GSD - file format specification and a library to read and write it"
-HOMEPAGE="
- https://github.com/glotzerlab/gsd/
- https://pypi.org/project/gsd/
-"
-SRC_URI="
- https://github.com/glotzerlab/gsd/releases/download/v${PV}/${MY_P}.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
-"
-RDEPEND="${DEPEND}"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- cd "${T}" || die
- epytest --pyargs gsd
-}