summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gssapi/gssapi-1.7.3-r1.ebuild')
-rw-r--r--dev-python/gssapi/gssapi-1.7.3-r1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/gssapi/gssapi-1.7.3-r1.ebuild b/dev-python/gssapi/gssapi-1.7.3-r1.ebuild
deleted file mode 100644
index e756fde5ea9c..000000000000
--- a/dev-python/gssapi/gssapi-1.7.3-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Low and high level wrappers around the GSSAPI C libraries"
-HOMEPAGE="https://github.com/pythongssapi/python-gssapi https://pypi.org/project/gssapi/"
-#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-# Needed to recythonise for Python 3.11
-SRC_URI="https://github.com/pythongssapi/python-gssapi/releases/download/v${PV}/python-${P}.tar.gz -> ${P}.gh.tar.gz"
-S="${WORKDIR}"/python-${P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~riscv x86"
-
-RDEPEND="
- dev-python/decorator[${PYTHON_USEDEP}]
- virtual/krb5
-"
-
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- virtual/krb5
- test? (
- dev-python/k5test[${PYTHON_USEDEP}]
- dev-python/parameterized[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- cd "${T}" || die
- epytest --pyargs gssapi
-}