summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hgdistver/hgdistver-0.25.ebuild')
-rw-r--r--dev-python/hgdistver/hgdistver-0.25.ebuild29
1 files changed, 0 insertions, 29 deletions
diff --git a/dev-python/hgdistver/hgdistver-0.25.ebuild b/dev-python/hgdistver/hgdistver-0.25.ebuild
deleted file mode 100644
index 5fafea392298..000000000000
--- a/dev-python/hgdistver/hgdistver-0.25.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="utility lib to generate python package version infos from mercurial tags"
-HOMEPAGE="https://pypi.org/project/hgdistver/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-vcs/git
- dev-vcs/mercurial
- )"
-RDEPEND=""
-
-python_test() {
- py.test || die "Tests failed under ${EPYTHON}"
-}