summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hgtools')
-rw-r--r--dev-python/hgtools/Manifest2
-rw-r--r--dev-python/hgtools/files/hgtools-doctest-2.0.2.patch11
-rw-r--r--dev-python/hgtools/hgtools-6.0.ebuild28
-rw-r--r--dev-python/hgtools/hgtools-6.3.ebuild30
-rw-r--r--dev-python/hgtools/metadata.xml16
5 files changed, 87 insertions, 0 deletions
diff --git a/dev-python/hgtools/Manifest b/dev-python/hgtools/Manifest
new file mode 100644
index 000000000000..2ac2f62165fc
--- /dev/null
+++ b/dev-python/hgtools/Manifest
@@ -0,0 +1,2 @@
+DIST hgtools-6.0.zip 37542 SHA256 14f3f4d94827c2d45e5a05ffd6efbe2484f662354a3dce2d8d1a29df1b05dd5a SHA512 86443caa03ff5c8fe3b2f5d503c8d28ddc8e29f4818fb7d3b51233b79eb4977c98bd83ccdba0612c3c17ecddacd6d7c7b283dc6ffc935eeb7a5b1a099324e9af WHIRLPOOL d8517f2b6a769201246a5072c971880b4ae52cdfc8aec2f619cd642337eb3cfdf5abee06aa91792a8380c0d81f9a68949a9efa3f44a29a3218b8d9bea8601802
+DIST hgtools-6.3.zip 39805 SHA256 1d0ef6ceaba1673e6923b17d7f09c5ae2f4394d16ef80562812987a27e7836ff SHA512 b5654194f6fbaf37c2a63523b02371ca6af1d7b7f7a89938ba4e405076049a054fff5e6d0d4a8b53560cde7dfc4a1862c5359d710d91c208dd83611913f17a7f WHIRLPOOL efe5bca6ce0970f0199b5c757dd8fd0bd4a03ad64f4ef571e4dbae311afd22c753aa6831fc688718cbc8ef037700a3b81220dae318f82a0ea9fe4d4179cfe4e3
diff --git a/dev-python/hgtools/files/hgtools-doctest-2.0.2.patch b/dev-python/hgtools/files/hgtools-doctest-2.0.2.patch
new file mode 100644
index 000000000000..328e6eee54bd
--- /dev/null
+++ b/dev-python/hgtools/files/hgtools-doctest-2.0.2.patch
@@ -0,0 +1,11 @@
+--- hgtools-2.0.2/hgtools/versioning.py 2012-10-09 10:35:38.000000000 +0800
++++ hgtools-2.0.2.new/hgtools/versioning.py 2013-05-04 16:45:14.883913556 +0800
+@@ -60,7 +60,7 @@
+
+ def as_number(self):
+ """
+- >>> str(SummableVersion('1.9.3').as_number())
++ >>> str(round(SummableVersion('1.9.3').as_number(), 12))
+ '1.93'
+ """
+ def combine(subver, ver):
diff --git a/dev-python/hgtools/hgtools-6.0.ebuild b/dev-python/hgtools/hgtools-6.0.ebuild
new file mode 100644
index 000000000000..9400a2ead3b6
--- /dev/null
+++ b/dev-python/hgtools/hgtools-6.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Classes and setuptools plugin for Mercurial repositories"
+HOMEPAGE="https://bitbucket.org/jaraco/hgtools/"
+SRC_URI="mirror://pypi/h/${PN}/${P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+SLOT="0"
+IUSE="test"
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND="dev-vcs/mercurial"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ pushd "${BUILD_DIR}"/../ > /dev/null
+ py.test "${PN}"/tests || die
+}
diff --git a/dev-python/hgtools/hgtools-6.3.ebuild b/dev-python/hgtools/hgtools-6.3.ebuild
new file mode 100644
index 000000000000..43f808dc9633
--- /dev/null
+++ b/dev-python/hgtools/hgtools-6.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Classes and setuptools plugin for Mercurial repositories"
+HOMEPAGE="https://bitbucket.org/jaraco/hgtools/"
+SRC_URI="mirror://pypi/h/${PN}/${P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND="dev-vcs/mercurial"
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ pushd "${BUILD_DIR}"/../ > /dev/null
+ py.test "${PN}"/tests || die
+ popd > /dev/null
+}
diff --git a/dev-python/hgtools/metadata.xml b/dev-python/hgtools/metadata.xml
new file mode 100644
index 000000000000..af2c31f7fb35
--- /dev/null
+++ b/dev-python/hgtools/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Classes and setuptools plugin for Mercurial repositories
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">hgtools</remote-id>
+ <remote-id type="bitbucket">jaraco/hgtools</remote-id>
+ </upstream>
+</pkgmetadata>