summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/html5-parser/html5-parser-0.4.5.ebuild')
-rw-r--r--dev-python/html5-parser/html5-parser-0.4.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/html5-parser/html5-parser-0.4.5.ebuild b/dev-python/html5-parser/html5-parser-0.4.5.ebuild
new file mode 100644
index 000000000000..7ca21bb61c3c
--- /dev/null
+++ b/dev-python/html5-parser/html5-parser-0.4.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Fast C based HTML 5 parsing for python"
+HOMEPAGE="https://github.com/kovidgoyal/html5-parser/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="dev-libs/libxml2:="
+RDEPEND="${DEPEND}
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.8.0[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ # Soup is not used when lxml is available.
+ rm test/soup.py || die
+ distutils-r1_src_prepare
+}
+
+src_configure() {
+ export PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
+}
+
+python_test() {
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}