summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/httpcore')
-rw-r--r--dev-python/httpcore/Manifest1
-rw-r--r--dev-python/httpcore/httpcore-0.13.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/httpcore/Manifest b/dev-python/httpcore/Manifest
index b7e7fb9d804b..f76740ca2ad4 100644
--- a/dev-python/httpcore/Manifest
+++ b/dev-python/httpcore/Manifest
@@ -1 +1,2 @@
DIST httpcore-0.12.3.tar.gz 57587 BLAKE2B 3c0e7a210b21e54564c4c6077fadf66344b887662c71b05a1ad4a2c0224a4d703eccdf576d4443341176edee03b6776bfd49aaef2ea2f29f02614677e1dfad85 SHA512 b31535231dc2b6a5f1c9c0c538628f75360f04b4747b447ab0a7168ed32d0eabd463335c2f7fa782dcabb4cbc32891a2839ae50e0999d5a791c01b02533d38f0
+DIST httpcore-0.13.0.tar.gz 58310 BLAKE2B 29ed4ad768088c6226ece27cb82e2a1d8df32eba4cf446015b43360c330ec65b433f571ac8e13e4b8f8994ff6e097ce5bf79ae1b9561d940298172c66d539153 SHA512 28ed65d3b3b30a62e3f198d98ae77a3cc26bd80250f10a506851433b5572a6fdcab38bf0d670caea94dec43d5b61de21a3ea967a445041536cad68eb98cc12bc
diff --git a/dev-python/httpcore/httpcore-0.13.0.ebuild b/dev-python/httpcore/httpcore-0.13.0.ebuild
new file mode 100644
index 000000000000..65db85718369
--- /dev/null
+++ b/dev-python/httpcore/httpcore-0.13.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A minimal low-level HTTP client"
+HOMEPAGE="https://www.encode.io/httpcore/"
+SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/h11-0*[${PYTHON_USEDEP}]
+ =dev-python/sniffio-1*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # anyio and trio are not in the tree
+ sed -i 's/^@pytest.mark.\(anyio\|trio\)/@pytest.mark.skip/' \
+ tests/async_tests/test_*.py || die
+ sed -i '/^import trio/d' tests/utils.py || die
+ # pproxy is not in the tree, the associated fixture
+ # must be disabled to prevent errors during test setup
+ sed -i 's/def proxy_server().*/&\n pytest.skip()/' \
+ tests/conftest.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local skipped_tests=(
+ # Require Internet access or hypercorn (not in the tree)
+ tests/test_threadsafety.py::test_threadsafe_basic
+ tests/sync_tests/test_interfaces.py::test_http_request
+ tests/sync_tests/test_interfaces.py::test_https_request
+ tests/sync_tests/test_interfaces.py::test_http2_request
+ tests/sync_tests/test_interfaces.py::test_closing_http_request
+ tests/sync_tests/test_interfaces.py::test_connection_pool_get_connection_info
+ tests/sync_tests/test_interfaces.py::test_max_keepalive_connections_handled_correctly
+ tests/sync_tests/test_interfaces.py::test_explicit_backend_name
+ tests/sync_tests/test_interfaces.py::test_connection_timeout_tcp
+ tests/sync_tests/test_interfaces.py::test_broken_socket_detection_many_open_files
+ tests/sync_tests/test_retries.py::test_no_retries
+ tests/sync_tests/test_retries.py::test_retries_exceeded
+ tests/sync_tests/test_retries.py::test_retries_enabled
+ # Require hypercorn
+ tests/sync_tests/test_interfaces.py::test_connection_timeout_uds
+ )
+ epytest ${skipped_tests[@]/#/--deselect }
+}