summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/humanfriendly/humanfriendly-4.18.ebuild')
-rw-r--r--dev-python/humanfriendly/humanfriendly-4.18.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/dev-python/humanfriendly/humanfriendly-4.18.ebuild b/dev-python/humanfriendly/humanfriendly-4.18.ebuild
deleted file mode 100644
index f7b4b4a45d9e..000000000000
--- a/dev-python/humanfriendly/humanfriendly-4.18.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-PYTHON_REQ_USE="threads(+)"
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Human friendly output for text interfaces using Python"
-HOMEPAGE="https://pypi.org/project/humanfriendly
- https://github.com/xolox/python-humanfriendly
- https://humanfriendly.readthedocs.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-DEPEND="test? ( dev-python/capturer[${PYTHON_USEDEP}]
- dev-python/coloredlogs[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs
-
-python_test() {
- pytest -vv ${PN}/tests.py || die "Tests fail with ${EPYTHON}"
-}