summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/humanfriendly/humanfriendly-8.2.ebuild')
-rw-r--r--dev-python/humanfriendly/humanfriendly-8.2.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/humanfriendly/humanfriendly-8.2.ebuild b/dev-python/humanfriendly/humanfriendly-8.2.ebuild
deleted file mode 100644
index 03462a33c378..000000000000
--- a/dev-python/humanfriendly/humanfriendly-8.2.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7..9} )
-PYTHON_REQ_USE="threads(+)"
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Human friendly output for text interfaces using Python"
-HOMEPAGE="https://pypi.org/project/humanfriendly/
- https://github.com/xolox/python-humanfriendly/
- https://humanfriendly.readthedocs.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
-
-BDEPEND="
- test? (
- dev-python/capturer[${PYTHON_USEDEP}]
- dev-python/coloredlogs[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs
-
-python_test() {
- pytest -vv ${PN}/tests.py || die "Tests fail with ${EPYTHON}"
-}