summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hyperframe/hyperframe-6.0.1-r1.ebuild')
-rw-r--r--dev-python/hyperframe/hyperframe-6.0.1-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/hyperframe/hyperframe-6.0.1-r1.ebuild b/dev-python/hyperframe/hyperframe-6.0.1-r1.ebuild
new file mode 100644
index 000000000000..fd61495e21b9
--- /dev/null
+++ b/dev-python/hyperframe/hyperframe-6.0.1-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="HTTP/2 framing layer for Python"
+HOMEPAGE="
+ https://python-hyper.org/projects/hyperframe/en/latest/
+ https://pypi.org/project/hyperframe/
+ https://github.com/python-hyper/hyperframe/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+distutils_enable_tests pytest