summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/idna')
-rw-r--r--dev-python/idna/Manifest2
-rw-r--r--dev-python/idna/idna-1.1.ebuild24
-rw-r--r--dev-python/idna/idna-2.0.ebuild24
-rw-r--r--dev-python/idna/metadata.xml13
4 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/idna/Manifest b/dev-python/idna/Manifest
new file mode 100644
index 000000000000..468f6d384d70
--- /dev/null
+++ b/dev-python/idna/Manifest
@@ -0,0 +1,2 @@
+DIST idna-1.1.tar.gz 99242 SHA256 3dab514abd255ada7994a57161750e8f054b938bf7adb8b40b96f13df54efaed SHA512 eb7a3673641827899ab9a4ba56f214e1fd3d17370d05bb04464664c2752ba7636507c3f6a64c9e24d44a1dd566842ffc86ce01351c1bfcebc3248baab786b99c WHIRLPOOL 90c1e03b23f3765749778f41ad7eac5befd5122f0552cf1616c7e4f53ae1d3f68f964753bf050956d773b720d608479830d72eb0a94d62848eab86ab4491326e
+DIST idna-2.0.tar.gz 135150 SHA256 16199aad938b290f5be1057c0e1efc6546229391c23cea61ca940c115f7d3d3b SHA512 005f88e954f13ace584ced510752da58d1cb16ebfbeee10aeef5bec57b3c61a3a5d7ce0bb50deba6dc90b412607727bf94a95a785e91d6528cd8633961c142dc WHIRLPOOL d865420f1c5f648d12480af93a52e0b2d463064c34c57ce56022f6965c2e4f6a49244e7798b9fcc18a7c6517b98e88bf84dc52e0050abe2ce504365b5579d2b6
diff --git a/dev-python/idna/idna-1.1.ebuild b/dev-python/idna/idna-1.1.ebuild
new file mode 100644
index 000000000000..583c5446adf8
--- /dev/null
+++ b/dev-python/idna/idna-1.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Internationalized Domain Names in Applications (IDNA)"
+HOMEPAGE="https://github.com/kjd/idna"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~hppa ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/idna/idna-2.0.ebuild b/dev-python/idna/idna-2.0.ebuild
new file mode 100644
index 000000000000..52c85f14ce76
--- /dev/null
+++ b/dev-python/idna/idna-2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Internationalized Domain Names in Applications (IDNA)"
+HOMEPAGE="https://github.com/kjd/idna"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/idna/metadata.xml b/dev-python/idna/metadata.xml
new file mode 100644
index 000000000000..26e53561ceca
--- /dev/null
+++ b/dev-python/idna/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">idna</remote-id>
+ <remote-id type="github">kjd/idna</remote-id>
+ </upstream>
+</pkgmetadata>