summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/imread/imread-0.7.3.ebuild')
-rw-r--r--dev-python/imread/imread-0.7.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/imread/imread-0.7.3.ebuild b/dev-python/imread/imread-0.7.3.ebuild
new file mode 100644
index 000000000000..bf90e09c7893
--- /dev/null
+++ b/dev-python/imread/imread-0.7.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read Image Files"
+HOMEPAGE="http://luispedro.org/software/imread/ https://github.com/luispedro/imread"
+SRC_URI="https://github.com/luispedro/imread/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_sphinx docs \
+ 'dev-python/numpydoc'
+
+distutils_enable_tests setup.py