summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/imread')
-rw-r--r--dev-python/imread/Manifest1
-rw-r--r--dev-python/imread/imread-0.7.3.ebuild28
-rw-r--r--dev-python/imread/metadata.xml16
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/imread/Manifest b/dev-python/imread/Manifest
new file mode 100644
index 000000000000..e195ce43958b
--- /dev/null
+++ b/dev-python/imread/Manifest
@@ -0,0 +1 @@
+DIST imread-0.7.3.tar.gz 131492 BLAKE2B 060bcd8312f24f2966f840a6403486a9a9a2f6b9d033e92f0268594711f4fa06530c2a825103683b1041570c43c3af584faf10acf45a95e693dc83c81da4190d SHA512 401ec64fd4a65fac1cf2e1bd929cad00a8d704c6c03b8a10256d1e9c27cbc83b47a11567731a42c731aca3df9a5101b7ff90bb51f869695b1405c642e16486e7
diff --git a/dev-python/imread/imread-0.7.3.ebuild b/dev-python/imread/imread-0.7.3.ebuild
new file mode 100644
index 000000000000..bf90e09c7893
--- /dev/null
+++ b/dev-python/imread/imread-0.7.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read Image Files"
+HOMEPAGE="http://luispedro.org/software/imread/ https://github.com/luispedro/imread"
+SRC_URI="https://github.com/luispedro/imread/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_sphinx docs \
+ 'dev-python/numpydoc'
+
+distutils_enable_tests setup.py
diff --git a/dev-python/imread/metadata.xml b/dev-python/imread/metadata.xml
new file mode 100644
index 000000000000..7a3dcbaa2b98
--- /dev/null
+++ b/dev-python/imread/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>3dprint@gentoo.org</email>
+ <name>Gentoo 3D Printer Project</name>
+ </maintainer>
+ <longdescription>
+ IO with images and numpy arrays.
+ Mahotas-imread is a simple module with a small number of functions.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">cgohlke/tifffile</remote-id>
+ <remote-id type="pypi">tifffile</remote-id>
+ </upstream>
+</pkgmetadata>