summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ioflo/ioflo-1.7.4.ebuild')
-rw-r--r--dev-python/ioflo/ioflo-1.7.4.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-python/ioflo/ioflo-1.7.4.ebuild b/dev-python/ioflo/ioflo-1.7.4.ebuild
index 6bc509dcef22..c9bb199ea62e 100644
--- a/dev-python/ioflo/ioflo-1.7.4.ebuild
+++ b/dev-python/ioflo/ioflo-1.7.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -15,5 +15,9 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/setuptools-git-1.1[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -e 's:"setuptools_git[^"]*",::' -i setup.py || die
+ distutils-r1_python_prepare_all
+}