summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/isodate')
-rw-r--r--dev-python/isodate/isodate-0.5.1.ebuild17
-rw-r--r--dev-python/isodate/isodate-0.5.4.ebuild17
2 files changed, 18 insertions, 16 deletions
diff --git a/dev-python/isodate/isodate-0.5.1.ebuild b/dev-python/isodate/isodate-0.5.1.ebuild
index bcd182ced7f4..66864f910744 100644
--- a/dev-python/isodate/isodate-0.5.1.ebuild
+++ b/dev-python/isodate/isodate-0.5.1.ebuild
@@ -20,14 +20,15 @@ IUSE=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
python_test() {
- local test
- pushd "${BUILD_DIR}"/lib/
- for test in ${PN}/tests/test_*.py
- do
- if ! "${PYTHON}" $test; then
- die "Test $test failed under ${EPYTHON}"
+ local testfile
+ pushd "${BUILD_DIR}"/lib/ || die
+ for test in ${PN}/tests/test_*.py; do
+ if ! "${PYTHON}" "${testfile}"; then
+ die "Test ${testfile} failed under ${EPYTHON}"
fi
done
- # Give some order to the output salad
- einfo "Testsuite passed under ${EPYTHON}";einfo ""
+
+ # Give some order to the output salad.
+ einfo "Testsuite passed under ${EPYTHON}";
+ einfo ""
}
diff --git a/dev-python/isodate/isodate-0.5.4.ebuild b/dev-python/isodate/isodate-0.5.4.ebuild
index a9e5d814be19..f5351b07bf7e 100644
--- a/dev-python/isodate/isodate-0.5.4.ebuild
+++ b/dev-python/isodate/isodate-0.5.4.ebuild
@@ -20,14 +20,15 @@ IUSE=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
python_test() {
- local test
- pushd "${BUILD_DIR}"/lib/
- for test in ${PN}/tests/test_*.py
- do
- if ! "${PYTHON}" $test; then
- die "Test $test failed under ${EPYTHON}"
+ local testfile
+ pushd "${BUILD_DIR}"/lib/ || die
+ for test in ${PN}/tests/test_*.py; do
+ if ! "${PYTHON}" "${testfile}"; then
+ die "Test ${testfile} failed under ${EPYTHON}"
fi
done
- # Give some order to the output salad
- einfo "Testsuite passed under ${EPYTHON}";einfo ""
+
+ # Give some order to the output salad.
+ einfo "Testsuite passed under ${EPYTHON}";
+ einfo ""
}