summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/itsdangerous')
-rw-r--r--dev-python/itsdangerous/Manifest4
-rw-r--r--dev-python/itsdangerous/itsdangerous-0.21.ebuild20
-rw-r--r--dev-python/itsdangerous/itsdangerous-0.22.ebuild18
-rw-r--r--dev-python/itsdangerous/itsdangerous-0.23.ebuild28
-rw-r--r--dev-python/itsdangerous/itsdangerous-0.24.ebuild28
-rw-r--r--dev-python/itsdangerous/metadata.xml8
6 files changed, 106 insertions, 0 deletions
diff --git a/dev-python/itsdangerous/Manifest b/dev-python/itsdangerous/Manifest
new file mode 100644
index 000000000000..ea9abc4c17c6
--- /dev/null
+++ b/dev-python/itsdangerous/Manifest
@@ -0,0 +1,4 @@
+DIST itsdangerous-0.21.tar.gz 8595 SHA256 c760381fc09dc120e4b459f5ba39ed55ea21fd77ac9f4d4101c0c237d8fc9d9e SHA512 5164dda9d38d0d1c880f7782db12fe74b7f305057fa5507d788d6af2d49068a870313280ece6e4b019d0e5ba01f945ae7a54b205f289efda2602bad12cd401cd WHIRLPOOL 1359b8625a7865a590fd2d3d8fd667f6ad0b74d5b4bb90b9afd4b38e41479ed0e1f56f92ff55d57c24edc486711dbca36a6ee778b70b766ea6ba32c22793eadc
+DIST itsdangerous-0.22.tar.gz 9460 SHA256 9e63500ef4c2f30be66a69cd0def95966db889c32e7b4fe4dd8fc9c7ebe3f3fc SHA512 48a72c27d9eb9537efac8de5bd59a870d9b6b4622f02ea8247cc24f5c48ce186e32c0a2d438f2cadb000d06059b8f693afa51c85d5c2fcf30a16caf33da95aad WHIRLPOOL 68d9653eec7ba615361097e4bcef27387626c8de91970322b9964ac509417dbf437bcb9fb0e38c2777466d3303027a7f732a4015f912bc506bac798f2acf9326
+DIST itsdangerous-0.23.tar.gz 46176 SHA256 71c0bf6bde4dcc93d838415e728a961a7b16f324b8ae182525fbdadde9f55d62 SHA512 dbffc5c5b4f902a461dd51c2ea8f84916f3b383eefeaaae249a76b22335db464a399d3c16943d3c0f031a874fd91d2f971fa80016fdbedb06b161a65d789359f WHIRLPOOL 5f297ea18f2c0539a5e1d337da34ed361564efb3b6162b431864e681d9fefd5a2e54844e5c7756bb452380635dbfa555c4c19321500d1ff808dce4f68cde3e02
+DIST itsdangerous-0.24.tar.gz 46541 SHA256 cbb3fcf8d3e33df861709ecaf89d9e6629cff0a217bc2848f1b41cd30d360519 SHA512 2863b6e5fda178db59bd214c6d24d04422c1021bb41bf11598aba1cbc43053aff3bb1e0539940b5769de04b68c03e8bd01d728dcbfc4bd0ba05867688574a297 WHIRLPOOL 44338b9c489506b972c33bafa1437042c17f452e65095d3b7dc85bf1cbfa26fcc45b097a7e899ae5ccfa4e3727e9c0ea285e254f6318c74a61217da910a63a83
diff --git a/dev-python/itsdangerous/itsdangerous-0.21.ebuild b/dev-python/itsdangerous/itsdangerous-0.21.ebuild
new file mode 100644
index 000000000000..b9d69691b568
--- /dev/null
+++ b/dev-python/itsdangerous/itsdangerous-0.21.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Various helpers to pass trusted data to untrusted environments and back"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://pythonhosted.org/itsdangerous/ http://pypi.python.org/pypi/itsdangerous"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/itsdangerous/itsdangerous-0.22.ebuild b/dev-python/itsdangerous/itsdangerous-0.22.ebuild
new file mode 100644
index 000000000000..2ab929532a04
--- /dev/null
+++ b/dev-python/itsdangerous/itsdangerous-0.22.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Various helpers to pass trusted data to untrusted environments and back"
+HOMEPAGE="http://pythonhosted.org/itsdangerous/ http://pypi.python.org/pypi/itsdangerous"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/itsdangerous/itsdangerous-0.23.ebuild b/dev-python/itsdangerous/itsdangerous-0.23.ebuild
new file mode 100644
index 000000000000..61841f131259
--- /dev/null
+++ b/dev-python/itsdangerous/itsdangerous-0.23.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Various helpers to pass trusted data to untrusted environments and back"
+HOMEPAGE="http://pythonhosted.org/itsdangerous/ http://pypi.python.org/pypi/itsdangerous"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+# Required for running tests.py
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ if python_is_python3; then
+ 2to3 -f unicode -nw --no-diffs tests.py
+ fi
+ "${PYTHON}" tests.py || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/itsdangerous/itsdangerous-0.24.ebuild b/dev-python/itsdangerous/itsdangerous-0.24.ebuild
new file mode 100644
index 000000000000..0d1114fca770
--- /dev/null
+++ b/dev-python/itsdangerous/itsdangerous-0.24.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Various helpers to pass trusted data to untrusted environments and back"
+HOMEPAGE="http://pythonhosted.org/itsdangerous/ http://pypi.python.org/pypi/itsdangerous"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+# Required for running tests.py
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ if python_is_python3; then
+ 2to3 -f unicode -nw --no-diffs tests.py
+ fi
+ "${PYTHON}" tests.py || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/itsdangerous/metadata.xml b/dev-python/itsdangerous/metadata.xml
new file mode 100644
index 000000000000..d204c07a0838
--- /dev/null
+++ b/dev-python/itsdangerous/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">itsdangerous</remote-id>
+ </upstream>
+</pkgmetadata>