summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jaraco-logging/jaraco-logging-3.0.0-r1.ebuild')
-rw-r--r--dev-python/jaraco-logging/jaraco-logging-3.0.0-r1.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/jaraco-logging/jaraco-logging-3.0.0-r1.ebuild b/dev-python/jaraco-logging/jaraco-logging-3.0.0-r1.ebuild
deleted file mode 100644
index f2dc6af3ffac..000000000000
--- a/dev-python/jaraco-logging/jaraco-logging-3.0.0-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Additional facilities to supplement Python's stdlib logging module"
-HOMEPAGE="https://github.com/jaraco/jaraco.logging"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# TODO: remove six
-# https://github.com/jaraco/jaraco.logging/pull/1
-RDEPEND="
- >=dev-python/namespace-jaraco-2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/tempora[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs '>=dev-python/jaraco-packaging-3.2' \
- '>=dev-python/rst-linker-1.9'
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_test() {
- # Override pytest options to skip flake8
- PYTHONPATH=. pytest -vv --override-ini="addopts=--doctest-modules" \
- || die "tests failed with ${EPYTHON}"
-}
-
-# https://wiki.gentoo.org/wiki/Project:Python/Namespace_packages#File_collisions_between_pkgutil-style_packages
-python_install() {
- rm "${BUILD_DIR}"/lib/jaraco/__init__.py || die
- # note: eclass may default to --skip-build in the future
- distutils-r1_python_install --skip-build
-}