summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jedi')
-rw-r--r--dev-python/jedi/Manifest1
-rw-r--r--dev-python/jedi/jedi-0.12.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/jedi/Manifest b/dev-python/jedi/Manifest
index aa9d365820a9..9a60f7a3c2e2 100644
--- a/dev-python/jedi/Manifest
+++ b/dev-python/jedi/Manifest
@@ -1,2 +1,3 @@
DIST jedi-0.10.2.tar.gz 373879 BLAKE2B 8007b31dc6c96d9538ab141b976fd4554ea16f01bb277692534a2972a6dcf61ee809c7573a7a3f7c0eceb29505de6ffe3ec0a7234a427579333b453fc9cd9dbc SHA512 847b000894b5e17cf5582c88245989ce1f0e17b595c79a2cdf4cc7a805fe7360ea08f28ac31473408be795c9ea210c85541cffa5fc7e7119da8c0228eb509351
DIST jedi-0.11.1.tar.gz 332402 BLAKE2B bc0a8df89c3d8b6cccc387a22cc08f613c990c59e360c58ae1d2becf521a755892afa4972195f6e40ec3bb48b74b20a966034d0e5bcad5051f90e5b4cc082270 SHA512 61389704a318f89d12b053b786bfb6bda21d2696830c001d6d6e66191fc060d731bc05ea71f2e70725532dcbe109c5c7346a36d227e6f8ab0eb2512f4c1a8945
+DIST jedi-0.12.0.tar.gz 354329 BLAKE2B ef203f2ba57a90de1e16b80c8786fa25d6d459244873dfb22044aa6d080435efa976daeb80949c3fba41ca2f57feb5bfed255b3bb490e17b40b3f13dfbb31e14 SHA512 3e8280b16855cf2c891666f0fb02ac30d801279b72b5bcb64541ef7c152d9f9b165015405ee291cbccd6c9cb3c0481c24f30e6100cb4463888153021b946f16d
diff --git a/dev-python/jedi/jedi-0.12.0.ebuild b/dev-python/jedi/jedi-0.12.0.ebuild
new file mode 100644
index 000000000000..ce096b6c317f
--- /dev/null
+++ b/dev-python/jedi/jedi-0.12.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Autocompletion library for Python"
+HOMEPAGE="https://github.com/davidhalter/jedi"
+SRC_URI="https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/parso-0.1.1[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )"
+
+# various misc failures
+RESTRICT="test"
+
+src_prepare() {
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PYTHONPATH="${PYTHONPATH%:}${PYTHONPATH+:}${S}/test" py.test -v test \
+ || die "Tests failed under ${EPYTHON}"
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( "${S}"/docs/_build/html/. )
+ distutils-r1_python_install_all
+}