summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jinja2-time/jinja2-time-0.2.0-r1.ebuild')
-rw-r--r--dev-python/jinja2-time/jinja2-time-0.2.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/jinja2-time/jinja2-time-0.2.0-r1.ebuild b/dev-python/jinja2-time/jinja2-time-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..e1f064fa6fd8
--- /dev/null
+++ b/dev-python/jinja2-time/jinja2-time-0.2.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Jinja2 Extension for Dates and Times"
+HOMEPAGE="
+ https://github.com/hackebrot/jinja2-time/
+ https://pypi.org/project/jinja2-time/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm64 ~ppc64 ~riscv x86"
+
+RDEPEND="
+ dev-python/arrow[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-arrow-compat.patch
+)
+
+distutils_enable_tests pytest