summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jsonpatch/jsonpatch-1.9.ebuild')
-rw-r--r--dev-python/jsonpatch/jsonpatch-1.9.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/jsonpatch/jsonpatch-1.9.ebuild b/dev-python/jsonpatch/jsonpatch-1.9.ebuild
new file mode 100644
index 000000000000..9217cf1e5c7d
--- /dev/null
+++ b/dev-python/jsonpatch/jsonpatch-1.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Apply JSON-Patches according to
+ http://tools.ietf.org/html/draft-pbryan-json-patch-04"
+HOMEPAGE="https://github.com/stefankoegl/python-json-patch"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/jsonpointer-1.5[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+ "${PYTHON}" ext_tests.py || die "Tests fail with ${EPYTHON}"
+}