summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/junit-xml/junit-xml-1.8.ebuild')
-rw-r--r--dev-python/junit-xml/junit-xml-1.8.ebuild29
1 files changed, 0 insertions, 29 deletions
diff --git a/dev-python/junit-xml/junit-xml-1.8.ebuild b/dev-python/junit-xml/junit-xml-1.8.ebuild
deleted file mode 100644
index 0241c4f5563e..000000000000
--- a/dev-python/junit-xml/junit-xml-1.8.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python module for creating JUnit XML test result documents"
-HOMEPAGE="https://pypi.org/project/junit-xml https://github.com/kyrus/python-junit-xml"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- py.test -v || die "testing failed with ${EPYTHON}"
-}