summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jupyter_packaging/jupyter_packaging-0.10.2.ebuild')
-rw-r--r--dev-python/jupyter_packaging/jupyter_packaging-0.10.2.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/jupyter_packaging/jupyter_packaging-0.10.2.ebuild b/dev-python/jupyter_packaging/jupyter_packaging-0.10.2.ebuild
deleted file mode 100644
index 593c51be660f..000000000000
--- a/dev-python/jupyter_packaging/jupyter_packaging-0.10.2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Tools to help build and install Jupyter Python packages"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/tomlkit[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- dev-python/deprecation[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Skip the tests that try to install things or call pip
- rm tests/test_build_api.py \
- tests/test_datafiles_install.py \
- tests/test_install.py || die
- # Permission Denied (tries to write to site_packages)
- sed -i -e 's/test_create_cmdclass/_&/' \
- tests/test_deprecated.py || die
- distutils-r1_python_prepare_all
-}