summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/keyring/keyring-21.3.1.ebuild')
-rw-r--r--dev-python/keyring/keyring-21.3.1.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/keyring/keyring-21.3.1.ebuild b/dev-python/keyring/keyring-21.3.1.ebuild
deleted file mode 100644
index 669cfb619df2..000000000000
--- a/dev-python/keyring/keyring-21.3.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Provides access to the system keyring service"
-HOMEPAGE="https://github.com/jaraco/keyring"
-SRC_URI="https://github.com/jaraco/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="PSF-2"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc"
-
-RDEPEND="
- dev-python/secretstorage[${PYTHON_USEDEP}]
- dev-python/entrypoints[${PYTHON_USEDEP}]
- dev-python/jeepney[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
- ' pypy3 python3_{5,6,7})
-"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- dev-python/jaraco-packaging \
- dev-python/rst-linker
-
-python_prepare_all() {
- sed -i -e 's:--flake8 --black --cov --mypy::' pytest.ini || die
- rm tests/backends/test_kwallet.py || die
-
- distutils-r1_python_prepare_all
-
- export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-}