summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/keyring/keyring-23.0.1.ebuild')
-rw-r--r--dev-python/keyring/keyring-23.0.1.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/keyring/keyring-23.0.1.ebuild b/dev-python/keyring/keyring-23.0.1.ebuild
deleted file mode 100644
index 4e13723b2dd4..000000000000
--- a/dev-python/keyring/keyring-23.0.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7..10} )
-inherit distutils-r1
-
-DESCRIPTION="Provides access to the system keyring service"
-HOMEPAGE="https://github.com/jaraco/keyring"
-SRC_URI="https://github.com/jaraco/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="PSF-2"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~x64-macos"
-
-RDEPEND="
- dev-python/secretstorage[${PYTHON_USEDEP}]
- dev-python/entrypoints[${PYTHON_USEDEP}]
- dev-python/jeepney[${PYTHON_USEDEP}]
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- dev-python/jaraco-packaging \
- dev-python/rst-linker
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- local deselect=(
- # this test fails if importlib-metadata returns more than one
- # entry, i.e. when keyring is installed already
- tests/test_packaging.py::test_entry_point
- )
- epytest --ignore tests/backends/test_kwallet.py ${deselect[@]/#/--deselect }
-}