summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/kgb/kgb-7.1.1.ebuild')
-rw-r--r--dev-python/kgb/kgb-7.1.1.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/dev-python/kgb/kgb-7.1.1.ebuild b/dev-python/kgb/kgb-7.1.1.ebuild
index c7f92d10cca2..9167429c4851 100644
--- a/dev-python/kgb/kgb-7.1.1.ebuild
+++ b/dev-python/kgb/kgb-7.1.1.ebuild
@@ -1,24 +1,22 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
-inherit distutils-r1
+inherit distutils-r1 pypi
-MY_P=${PN}-release-${PV}
DESCRIPTION="Python function spy support for unit tests"
HOMEPAGE="
https://github.com/beanbaginc/kgb/
https://pypi.org/project/kgb/
"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 arm64 x86"
distutils_enable_tests pytest